Install MediaWiki/Modifications pour la 1.39.1

Article publié le :   31 décembre 2022 19:12:06


Install MediaWiki/Modifications pour la 1.39.1
Nom mediawiki
Version 1.39.1


   Install_MediaWiki


Installation

  • sauvegarde du fichier LocalSettings.php
  • décompression de la version sur un nouveau répertoire, puis recopie sur le répertoire d'installation de MediaWiki


J'ai récupéré le targz mediawiki-1.39.1
puis je l'ai dézippé à l'aide d'un script php upgrade.php
//supression anciens répertoires
system("rm -rf ../MediaWiki/bin ../MediaWiki/cache ../MediaWiki/docs ../MediaWiki/includes ../MediaWiki/langages");
system("rm -rf  ../MediaWiki/maintenance ../MediaWiki/mw-config ../MediaWiki/resources ../MediaWiki/serialized ../MediaWiki/tests");
//dézipper
system("tar -C  ../MediaWiki --strip-components 1 -zxf ../tmp/mediawiki-1.39.1.tar.gz ");


  • lancement de l'installation
http://www.jltryoen.fr/MediaWiki/mw-config/


=> mise à jour de la base de données
  • reprise/vérification du fichier LocalSettings.php
 



Semantic MediaWiki

  • désactiver Semantic, pour cela modifier le fichier LocalSettings.php
##enableSemantics('www.jltryoen.fr/wiki/');
#require_once( "$IP/extensions/SemanticForms/SemanticForms.php");
#require_once( "$IP/extensions/SemanticExtraSpecialProperties/SemanticExtraSpecialProperties.php");
#require_once( "$IP/extensions/SemanticFormsInputs/SemanticFormsInputs.php");


Il est nécessaire de rétablir après l'installation le fichier composer.json

pour récupérer 

   MediaWiki/Semantic_MediaWiki

et de rétablir Semantic dans le fichier LocalSettings.php


J'ai utilisé composer-merge-plugin qui permet d'utiliser un fichier séparé pour les extensions : composer.local.json

composer.local.json
{
        "require": {        
                "mediawiki/semantic-media-wiki": "~4.0.0",
                "mediawiki/semantic-result-formats": "~4.0.0",
                "mediawiki/semantic-extra-special-properties": "~3.x-dev",
                "simplehtmldom/simplehtmldom": "~2.0-RC2"
        }
}


A noter que l'extension SemanticMediawiki n'est pas compatible avec php 8.x

Une fois SemanticMediaWiki rétabli dans les fichiers (ajouter désormais les lignes dans le fichier LocalSettings.php )

wfLoadExtension( 'SemanticMediaWiki' );
enableSemantics( $semanticURL, true );


lancer un update avec composer
composer update --no-dev


A noter que ma version de composer n'était plus à jour
Voir https://getcomposer.org/download/


php composer-setup.php --v 2.2


j'ai eu besoin pour SemanticMediaWiki de mettre à jour la base de données (répertoire extensions/SemanticMediawiki/maintenance 
php setupstore.php